Elevated latency in Florida

Incident Report for NVIDIA GeForce NOW

Resolved

This incident has been resolved.
Posted Jun 10, 2026 - 15:23 PDT

Update

We are continuing to monitor for any further issues.
Posted Jun 10, 2026 - 15:22 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 10, 2026 - 15:21 PDT

Investigating

Users connecting to the Florida location through AT&T may experience degraded performance and suboptimal streaming experience
Posted Jun 10, 2026 - 08:56 PDT
This incident affected: Florida (USA) [RTX 5080] (NP-MIA-03, NP-MIA-04 [RTX 5080]).