PC Users not able to launch GeForce NOW!
Incident Report for NVIDIA GeForce NOW
Resolved
NVIDIA is glad to inform you that the recent login issues have been resolved. Thank you for your patience!
Posted Jan 21, 2021 - 21:39 PST
Investigating
We are having an issue with GeForce NOW logins. Please bear with us as we resolve this issue.
Posted Jan 21, 2021 - 20:52 PST
This incident affected: NVIDIA Global Services.