S.T.A.L.K.E.R. 2: Heart of Chornobyl maintenance

Incident Report for NVIDIA GeForce NOW

Identified

Please use these instructions to play S.T.A.L.K.E.R. 2 Cost of Hope DLC on GeForce NOW: https://nvidia.custhelp.com/app/answers/detail/a_id/5892
Posted Sep 01, 2026 - 00:00 PDT

Investigating

We are currently working to resolve an issue affecting S.T.A.L.K.E.R. 2: Heart of Chornobyl on Steam. We will make it available to play as soon as the issue is resolved.
Posted Aug 20, 2026 - 16:02 PDT