Users may experience longer wait times in certain regions

Incident Report for NVIDIA GeForce NOW

Resolved

This incident has been resolved.
Posted Mar 20, 2025 - 14:25 PDT

Monitoring

All GFN services and regions are operating normally,
Posted Mar 19, 2025 - 17:19 PDT

Update

We are continuing to work on this issue.
Posted Mar 19, 2025 - 08:14 PDT

Update

We are continuing to work on a fix for this issue.
Posted Mar 18, 2025 - 11:29 PDT

Update

Some users may see periodic queuing and some intermittent errors. Service issues are actively being resolved.
Posted Mar 18, 2025 - 11:28 PDT

Update

Some users may see periodic queuing and some intermittent errors. Service issues are actively being resolved.
Posted Mar 18, 2025 - 03:54 PDT

Update

Service issues are being addressed. Users will experience high queue times and intermittent errors.
Posted Mar 18, 2025 - 00:14 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 17, 2025 - 19:46 PDT

Update

We are continuing to investigate this issue.
Posted Mar 17, 2025 - 19:45 PDT

Investigating

We are currently working on the issue.
Posted Mar 17, 2025 - 18:24 PDT
This incident affected: NVIDIA Global Services.