Sign-in errors (0xC192000C) and missing game library entries — mitigated, monitoring

Incident Report for NVIDIA GeForce NOW

Resolved

This incident has been resolved.
Posted May 24, 2026 - 02:30 PDT

Update

We are continuing to monitor for any further issues.
Posted May 23, 2026 - 19:06 PDT

Monitoring

Users were seeing errors (0xC192000C) when accessing GeForce Now. Additionally, some games expected were not being listed when login was successful.

We have mitigated the issue, and the user experience has returned to normal. We are actively monitoring.
Posted May 23, 2026 - 12:34 PDT
This incident affected: NVIDIA Global Services.