Origin game issue

Incident Report for NVIDIA GeForce NOW

Resolved

This incident has been resolved.
Posted Jan 04, 2023 - 10:48 PST

Investigating

As part of Electronic Arts’ transition from Origin to the EA app, some Origin games on GeForce NOW have been moved to maintenance while we add support for the EA app.
Posted Dec 08, 2022 - 14:06 PST