Genshin Impact maintenance

Incident Report for NVIDIA GeForce NOW

Resolved

This incident has been resolved.
Posted Feb 14, 2025 - 08:58 PST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 11, 2025 - 19:17 PST

Investigating

We are currently working to resolve Genshin Impact launch issue. We will make the game available to play as soon as the issue is resolved.
Posted Feb 11, 2025 - 18:35 PST