Call of Duty XBOX intermittent launch issue
Incident Report for NVIDIA GeForce NOW
Resolved
This incident has been resolved.
Posted Nov 20, 2024 - 09:09 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 19, 2024 - 08:11 PST
Investigating
We are investigating Call of Duty XBOX intermittent launch issue.
Posted Nov 14, 2024 - 13:47 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 05, 2024 - 14:21 PST
Update
We are investigating an intermittent Call of Duty issue on Xbox due to prolonged game data synchronization from previous game sessions. We are working with our partners Activision and Microsoft to address this issue.
Posted Nov 01, 2024 - 15:04 PDT
Investigating
We are investigating Call of Duty XBOX intermittent launch issue due to prolonged game data synchronization from previous game session.
Posted Oct 28, 2024 - 13:14 PDT
This incident affected: NVIDIA Global Services.