Divinity: Original Sin 2 is under maintenance
Incident Report for NVIDIA GeForce NOW
Resolved
This incident has been resolved and the game is now available for end users.
Posted Sep 30, 2021 - 04:42 PDT
Investigating
Divinity: Original Sin 2 is under maintenance. The GeForce NOW team is working on a fix with the latest game update.
Posted Sep 28, 2021 - 07:56 PDT
This incident affected: NVIDIA Global Services.