Long patching for Call of Duty HQ
Incident Report for NVIDIA GeForce NOW
Update
Call of Duty HQ Steam is currently only available in English. We are working on bringing back other languages support.
Posted Oct 21, 2024 - 21:51 PDT
Investigating
We are experiencing a delay in applying the latest patch for Call of Duty HQ on Steam and Battle.net. We are working on making the game available again as soon as possible.
Posted Oct 21, 2024 - 13:59 PDT
This incident affects: NVIDIA Global Services.