Fortnite is experiencing some login issues
Incident Report for NVIDIA GeForce NOW
Resolved
The issue impacting Fortnite login for connected accounts has been fully resolved. The account linking feature has now been re-enabled.
Posted Jul 24, 2021 - 10:28 PDT
Update
We are continuing to work on a fix for this issue.
Posted Jul 23, 2021 - 19:20 PDT
Identified
We were seeing an intermittent issue of users not being able to login into Fortnite for connected accounts. We have mitigated the issue. Account linking has been temporarily disabled.
Posted Jul 23, 2021 - 17:24 PDT
This incident affected: NVIDIA Global Services.