Wuthering Waves in maintenance

Incident Report for NVIDIA GeForce NOW

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 10, 2026 - 00:23 PDT

Investigating

We are currently working to resolve an issue affecting Wuthering Waves. We will make it available to play as soon as the issue is resolved.
Posted Apr 09, 2026 - 22:23 PDT