Long patching

Incident Report for NVIDIA GeForce NOW

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 14, 2025 - 16:44 PDT

Investigating

We are experiencing a delay in applying the latest patches. We have also observed games disappearing from the GeForce NOW app. We are working on making games available again as soon as possible.
Posted Mar 14, 2025 - 15:08 PDT