Apex Legends on Steam not launching
Incident Report for NVIDIA GeForce NOW
Resolved
Apex Legends on Steam now launches properly. Please note that it may take a few minutes for the loading screen to finish before the game starts. The game has been taken out of maintenance mode and is available to play.
Posted Feb 22, 2021 - 13:16 PST
Monitoring
Resolved- Apex Legends on Steam now launches properly. The game has been taken out of maintenance mode and is available to play.
Posted Feb 22, 2021 - 12:37 PST
This incident affected: NVIDIA Global Services.