Some Games are slow loading in SFM Zones
Incident Report for NVIDIA GeForce NOW
Resolved
This incident has been resolved as of Jun 16, 06:15 PM PDT.
Posted Jun 17, 2021 - 06:08 PDT
Investigating
We are investigating an incident that is causing games to load slowly in our Safmar zones. Please bear with us as we look into this. Thank you for your patience.
Posted Jun 16, 2021 - 04:40 PDT