NVIDIA regrets to inform you that we are experiencing long patching times for Warframe on GeForce NOW. We are working on finishing this process. Thank you for your patience!
Incident Report for NVIDIA GeForce NOW
Resolved
This incident has been resolved.
Posted Dec 03, 2020 - 07:14 PST
Investigating
We are currently investigating this issue.
Posted Dec 03, 2020 - 06:46 PST
This incident affected: NVIDIA Global Services.