Extended queue times in several GeForce NOW zones
Incident Report for NVIDIA GeForce NOW
Resolved
This incident has been resolved.
Posted Dec 21, 2020 - 09:35 PST
Update
We are continuing to monitor for any further issues.
Posted Dec 21, 2020 - 09:35 PST
Monitoring
A fix to the issue has been implemented, we are monitoring the results. Thank you for your patience!
Posted Dec 21, 2020 - 07:50 PST
Update
We are continuing to investigate this issue.
Posted Dec 21, 2020 - 07:29 PST
Investigating
NVIDIA regrets to inform you of extended queue time in several GeForce NOW zones. We are aware of the issue and are currently investigating it. Thank you for your patience!
Posted Dec 21, 2020 - 06:33 PST
This incident affected: NVIDIA Global Services.