Lost ARK game is in maintenance
Incident Report for NVIDIA GeForce NOW
Resolved
This incident has been resolved.
Posted Jul 10, 2024 - 08:58 PDT
Investigating
Lost ARK is in maintenance and is unavailable for play.
Posted Jul 09, 2024 - 20:43 PDT
This incident affected: KR GFN1 - Alliance Partner (NPA-GKR-SEL-01, NPA-GKR-SEL-02).