Epic Online Services update request when launching Epic Games Store games

Incident Report for NVIDIA GeForce NOW

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 06, 2026 - 18:34 PDT

Investigating

We are investigating an issue with Epic Online Services update request when launching Epic Games Launcher games. Players are advised to click on minimized game window to proceed with the game launch.
Posted Jun 05, 2026 - 19:20 PDT