The Install to Play feature has been Enabled. Customers in EMEA were experiencing Intermittent Errors due to High Demand - Resolved

Incident Report for NVIDIA GeForce NOW

Update

The Install to Play feature is now enabled.
Posted Oct 11, 2025 - 15:02 PDT

Update

We are continuing to monitor for any further issues.
Posted Oct 11, 2025 - 15:00 PDT

Update

We are continuing to monitor for any further issues.
Posted Oct 10, 2025 - 17:31 PDT

Monitoring

Starting 10/10 8am PST: Users in EMEA have been experiencing issues when loading the client and launching games. These issues have been addressed as of 10/10 1pm PST, and we are actively monitoring the user experience globally.

The Install to Play feature has been disabled temporarily.
Posted Oct 10, 2025 - 17:25 PDT
This incident affects: NVIDIA Global Services.