Long patching time for games
Incident Report for NVIDIA GeForce NOW
Resolved
This incident has been resolved.
Posted Mar 25, 2023 - 17:02 PDT
Identified
We are experiencing a delay in applying the latest patches to games.
Posted Mar 25, 2023 - 07:54 PDT
This incident affected: NVIDIA Global Services.