Long patching times for games

Incident Report for NVIDIA GeForce NOW

Resolved

This incident has been resolved.
Posted Jan 27, 2023 - 09:14 PST

Monitoring

A fix has been implemented and we are monitoring.
Posted Jan 26, 2023 - 14:46 PST