Xbox automatic sign-on
Incident Report for NVIDIA GeForce NOW
Resolved
This incident has been resolved.
Posted Aug 22, 2024 - 09:37 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 22, 2024 - 08:29 PDT
Investigating
We are aware that EU-West users are not getting Xbox automatic sign-on when playing Xbox games. Users can select another server from the GeForce NOW application until this is fixed.
Posted Aug 22, 2024 - 08:10 PDT
This incident affected: NVIDIA Global Services.