Connection Errors in EMEA

Incident Report for NVIDIA GeForce NOW

Monitoring

The fix is still being monitored. Thank you for your patience as we address the issue.
Posted Sep 27, 2025 - 10:48 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 26, 2025 - 17:43 PDT

Monitoring

We have addressed the issue impacting users accessing GFN services in EMEA and are now monitoring. We observed connection issues in US EAST regions and addressed the issue. Monitoring for further issues.
Posted Sep 26, 2025 - 14:52 PDT

Investigating

We are investigating intermittent connection errors to GFN services in EMEA.
Posted Sep 26, 2025 - 11:50 PDT
This incident affects: NVIDIA Global Services.