Issue with Battle.net

Incident Report for NVIDIA GeForce NOW

Resolved

This incident has been resolved
Posted Jan 08, 2026 - 17:59 PST

Investigating

We are currently investigating an issue with Battle.net and related games not being accessible.
Posted Jan 08, 2026 - 14:54 PST
This incident affected: NVIDIA Global Services.