THRONE AND LIBERTY mouse movement
Incident Report for NVIDIA GeForce NOW
Resolved
This incident has been resolved.
Posted Oct 08, 2024 - 06:39 PDT
Monitoring
We released a fix which allows users to use Classic Mode without needing to enable “Display the Mouse Cursor While Rotating” in the settings.
Posted Oct 07, 2024 - 10:09 PDT
Update
We are currently working to resolve an issue affecting THRONE AND LIBERTY camera rotation when playing in Classic Mode. Please follow the instructions in this knowledge base article https://nvidia.custhelp.com/app/answers/detail/a_id/5588 to workaround the issue. We will continue to investigate a fix for all users.
Posted Oct 04, 2024 - 09:56 PDT
Investigating
We are currently working to resolve an issue affecting Throne and Liberty camera controls. We will make them available to play as soon as the issue is resolved.
Posted Oct 04, 2024 - 06:37 PDT
This incident affected: NVIDIA Global Services.