Fortnite performance issues

Incident Report for NVIDIA GeForce NOW

Resolved

This incident has been resolved.
Posted Nov 30, 2022 - 10:38 PST

Investigating

We have detected some performance issues with Fortnite and are working on resolving them.
Posted Nov 22, 2022 - 11:23 PST