EA App Remember Me issue

Incident Report for NVIDIA GeForce NOW

Resolved

This incident has been resolved.
Posted Mar 23, 2026 - 08:41 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 21, 2026 - 11:21 PDT

Investigating

We are currently working to resolve an issue with "Remember me" feature in EA App. Players might need to enter their username and password before launching the game on GeForce NOW.
Posted Mar 11, 2026 - 10:55 PDT