Patching Issues with Ubisoft games
Incident Report for NVIDIA GeForce NOW
Resolved
We have resolved patching problems with Ubisoft games, such as Assassin’s Creed: Valhalla and Tom Clancy’s Rainbow Six Siege. If you experience any of these problems, please send us in-app feedback. We are actively working with Ubisoft to resolve this issue.
Posted Sep 10, 2021 - 11:26 PDT
Investigating
We are currently experiencing problems patching Ubisoft games, such as Assassin’s Creed: Valhalla and Tom Clancy’s Rainbow Six Siege. Some Ubisoft games may require a patch on launch, or might not be able to apply a patch properly during your game session. You may also experience longer than normal game maintenance times for the Ubisoft games. If you experience any of these problems, please send us in-app feedback. We are actively working with Ubisoft to resolve this issue.
Posted Sep 08, 2021 - 13:01 PDT