Zone issue
Incident Report for NVIDIA GeForce NOW
Resolved
This incident has been resolved.
Posted Oct 09, 2021 - 04:09 PDT
Update
We are continuing to investigate this issue.
Posted Oct 09, 2021 - 02:23 PDT
Update
We are continuing to investigate this issue.
Posted Oct 09, 2021 - 01:15 PDT
Investigating
We are currently investigating issue in zone NPA-TWM-TPE-01. We are working on restoring it as soon as possible.
Posted Oct 09, 2021 - 01:01 PDT
This incident affected: TW TWM1 - Alliance Partner (NPA-TWM-TPE-01).