Error launching some Steam games
Incident Report for NVIDIA GeForce NOW
Resolved
This incident has been resolved.
Posted May 12, 2023 - 07:51 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 10, 2023 - 12:03 PDT
Update
Resolved - now monitoring.
Posted May 10, 2023 - 12:02 PDT
Investigating
We are currently investigating an issue with launching some Steam games. Users can try workaround this issue by changing your local operating system language to U.S. English, which can allow some games to work.
Posted May 03, 2023 - 10:52 PDT
This incident affected: NVIDIA Global Services.