Issues accessing DLC content. 10:51 PM PDT, 10/21/2020
Incident Report for NVIDIA GeForce NOW
Resolved
This issue has been resolved.
Posted Oct 21, 2020 - 01:17 PDT
Identified
NVIDIA is aware that some members are having issues accessing DLC content that they've purchased, and in some cases already played. We're currently investigating and will provide updates on this page. Thank you for your patience!
Posted Oct 20, 2020 - 22:51 PDT
This incident affected: NVIDIA Global Services.