Customers are able to launch games. - Service has been restored

Incident Report for NVIDIA GeForce NOW

Update

Please read this knowledge base article for information on membership compensation related to the service interruption.

https://nvidia.custhelp.com/app/answers/detail/a_id/5714
Posted Sep 12, 2025 - 12:31 PDT

Update

We are continuing to monitor for any further issues. Investigating - Feature tags on games (RTX, HDR, Reflex, etc) are not currently visible. The features still work in-game for supported titles.
Posted Sep 11, 2025 - 22:51 PDT

Monitoring

We have mitigated the issue impacting users and are closely monitoring all services.
Posted Sep 11, 2025 - 22:50 PDT

Update

We are actively working on the current issue. Customers continue to see issues when loading content and launching games.
Posted Sep 11, 2025 - 21:21 PDT

Update

We are continuing to work on a fix for this issue.
Posted Sep 11, 2025 - 15:28 PDT

Identified

We are actively working to mitigate the current issues.
Posted Sep 11, 2025 - 13:02 PDT

Update

Investigating - GeForce NOW is experiencing high demand resulting in GeForce NOW apps not loading or games not launching. We are actively investigating the issue.
Posted Sep 11, 2025 - 11:26 PDT

Investigating

GeForce NOW is experiencing high demand resulting in users experience intermittent errors when launching games.
Posted Sep 11, 2025 - 10:26 PDT
This incident affects: NVIDIA Global Services.