Users may see longer wait times for search results.
Incident Report for NVIDIA GeForce NOW
Resolved
This incident has been resolved.
Posted Nov 25, 2020 - 11:00 PST
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 25, 2020 - 09:29 PST
This incident affected: NVIDIA Global Services.