Dying Light - Epic Games Store launch issues
Incident Report for NVIDIA GeForce NOW
Resolved
This incident has been resolved.
Posted May 16, 2023 - 11:22 PDT
Monitoring
A fix has been put in place and we are monitoring.
Posted May 10, 2023 - 13:32 PDT
Investigating
We are looking into reports of problems launching Dying Light - Epic Games Store version.
Posted Apr 10, 2023 - 10:35 PDT