EU West partial outage
Incident Report for NVIDIA GeForce NOW
Resolved
This incident has been resolved.
Posted Jun 13, 2024 - 17:00 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 13, 2024 - 12:30 PDT
Investigating
We are currently investigating an issue with several zones in EU West, they have been taken offline temporarily. We are working on restoring them as soon as possible.
Posted Jun 13, 2024 - 05:55 PDT