Xbox games intermittent launch issue

Incident Report for NVIDIA GeForce NOW

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 22, 2026 - 12:49 PDT

Investigating

We are investigating Xbox games intermittent launch issue affecting some players.
Posted Jun 21, 2026 - 21:27 PDT