Assassins Creed Odyssey is in maintenance
Incident Report for NVIDIA GeForce NOW
Resolved
This incident has been resolved.
Posted Jun 11, 2021 - 13:17 PDT
Investigating
GeForce NOW has placed Assassins Creed Odyssey into maintenance mode on our Japan data centers. We continue to help get this back online for our users. Thank you for your patience.
Posted Jun 11, 2021 - 12:26 PDT
This incident affected: JP East K1 - Alliance Partner (NPA-KDD-TYO-01).