Elevated latency in Poland

Incident Report for NVIDIA GeForce NOW

Resolved

This incident has been resolved.
Posted Sep 18, 2026 - 10:42 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 17, 2026 - 11:47 PDT

Investigating

Users connecting to the Poland location through Vodafone Ukraine may experience degraded performance and suboptimal streaming experience
Posted Sep 15, 2026 - 14:38 PDT
This incident affected: Poland [RTX-5080] (NP-WAW-01 [RTX-5080]).