Gamepad not working correctly on Windows PC

Incident Report for NVIDIA GeForce NOW

Monitoring

Microsoft is aware of this issue and has started to release a configuration change that should prevent the need for any manual steps outlined in our knowledgebase article https://nvidia.custhelp.com/app/answers/detail/a_id/5904/
If any user has manually made the change will continue to have it remain off with future updates.
Posted Sep 02, 2026 - 12:10 PDT

Investigating

We are investigating reports of gamepad registering as mouse input for GeForce NOW on Windows.
A workaround is available in our knowledge base article: https://nvidia.custhelp.com/app/answers/detail/a_id/5904/
Posted Sep 01, 2026 - 13:00 PDT
This incident affects: NVIDIA Global Services.