Steam Games launch issue
Incident Report for NVIDIA GeForce NOW
Resolved
NVIDIA is glad to inform you that the recent issues with Steam games in GeForce NOW were resolved. Thank you for your patience
Posted Oct 07, 2021 - 22:07 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 07, 2021 - 21:44 PDT
Investigating
NVIDIA regrets to inform you that we are experiencing issues with Steam games in GeForce NOW. We are working on a solution and monitoring the impact. Thank you for your patience!
Posted Oct 07, 2021 - 20:48 PDT
This incident affected: NVIDIA Global Services.