Battlefield 6 on Steam and EA app are now available.

Incident Report for NVIDIA GeForce NOW

Resolved

This incident has been resolved.
Posted Oct 11, 2025 - 15:06 PDT

Monitoring

We are monitoring our user experience.
Posted Oct 10, 2025 - 17:11 PDT
This incident affected: NVIDIA Global Services.