Global Outage for GeForce NOW. 12:33 PM, PDT, 5/11/2020
Incident Report for NVIDIA GeForce NOW
Resolved
This incident has been resolved.
Posted May 11, 2020 - 15:26 PDT
Investigating
We are currently investigating this issue.
Posted May 11, 2020 - 12:56 PDT
This incident affected: NVIDIA Global Services.