Increased queue times in GeForce NOW

Incident Report for NVIDIA GeForce NOW

Resolved

This incident has been resolved.
Posted Jun 26, 2025 - 16:40 PDT

Monitoring

We have observed increased queue times in GeForce NOW. The queue is recovering and we will continue to monitor.
Posted Jun 26, 2025 - 13:12 PDT