Cyberpunk 2077: Phantom Liberty
Incident Report for NVIDIA GeForce NOW
Resolved
This incident has been resolved.
Posted Sep 28, 2023 - 11:20 PDT
Monitoring
Cyberpunk 2077: Phantom Liberty is available for members playing on GOG.com, Epic Games Store and Steam. Please note, all Steam users will have to reinstall Cyberpunk 2077 on the GeForce NOW servers to play it now, even if you do not own the Phantom Liberty DLC. https://nvidia.custhelp.com/app/answers/detail/a_id/5483
Posted Sep 26, 2023 - 08:21 PDT
Investigating
We continue to work adding Steam and Epic Games Store platforms.
Posted Sep 25, 2023 - 20:00 PDT
Monitoring
Cyberpunk 2077: Phantom Liberty is available for members playing on GOG.com platform. We are also investigating reports of game crashes - such as “Cyberpunk has flatlined.”
Posted Sep 25, 2023 - 13:59 PDT
This incident affected: NVIDIA Global Services.