Windows Users with Non-English Characters in Their Username May Experience Issues on GeForce NOW Client v2.0.85.133

Incident Report for NVIDIA GeForce NOW

Monitoring

A new windows client has been released. Windows users whose username contains non-English characters will need to download and manually install the new client version v2.0.85.134 https://download.nvidia.com/gfnpc/GeForceNOW-release.exe.
Posted May 27, 2026 - 11:52 PDT

Investigating

Windows users whose username contains non-English characters may experience issues when using GeForce NOW client version v2.0.85.133, including inability to launch sessions or unexpected errors. As a temporary workaround, affected users can continue streaming via their browser.
Posted May 26, 2026 - 18:23 PDT