Genshin Impact is in maintenance

Incident Report for NVIDIA GeForce NOW

Resolved

This incident has been resolved.
Posted Jan 27, 2025 - 11:06 PST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 26, 2025 - 14:58 PST

Update

Honkai: Star Rail issue was resolved and we are monitoring the results. We continue investigating Genshin Impact launch issue.
Posted Jan 26, 2025 - 13:18 PST

Investigating

We are currently working to resolve C2720018 error affecting Honkai: Star Rail and Genshin Impact. We will make them available to play as soon as the issue is resolved.
Posted Jan 26, 2025 - 09:30 PST
This incident affected: NVIDIA Global Services.