Elevated packet loss and latency in Frankfurt

Incident Report for NVIDIA GeForce NOW

Resolved

This incident has been resolved.
Posted May 11, 2026 - 09:12 PDT

Investigating

Users connecting to the Frankfurt server location through their ISP may experience elevated packet loss and latency.
Posted May 09, 2026 - 12:08 PDT
This incident affected: Germany [RTX 5080] (NP-FRK-06, NP-FRK-07, NP-FRK-08 [RTX 5080]).