Baldur's Gate 3 in-game UI issue
Incident Report for NVIDIA GeForce NOW
Resolved
This incident has been resolved.
Posted Nov 07, 2023 - 11:14 PST
Monitoring
We've deployed a fix for UI issues with Baldur’s Gate 3, and the game is out of maintenance. Please use the Send Feedback tool in the GeForce NOW app if you experience any problems with the game
Posted Nov 05, 2023 - 09:29 PST
This incident affected: NVIDIA Global Services.