Streaming Quality Degradation on LG, Samsung TV & Older Browsers

Incident Report for NVIDIA GeForce NOW

Resolved

This incident has been resolved
Posted Feb 03, 2026 - 12:58 PST

Update

The issue affecting TVs is fixed, only users with very old browsers may experience reduced bandwidth or blurry image quality.
Posted Jan 28, 2026 - 20:07 PST

Investigating

We're currently investigating an issue affecting LG TVs, Samsung TVs, and older browsers where users may experience reduced bandwidth or blurry image quality.
Posted Jan 28, 2026 - 12:15 PST
This incident affected: NVIDIA Global Services.